Open Business Intelligence

La red del Business Intelligence

saludos tropa

a continuacion les muestro una imagen de una etl que estoy realizando

el problema que tengo es en el ultimo paso pues cuando hago la consulta este solo me retorna una ocurrencia, cuando deberian ser todas las existentes en el caso cuando la variable "idV" toma valor 0 y otro valor cuando la variable toma un valor determinado. En ambos casos este ultimo paso siempre retorna una sola ocurrencia, que es la primera que cumple con la condicion. Existe otro elemento en el cual pueda realizar este operacion?? Mil gracias

Visitas: 44

Respuestas a esta discusión

en serio?? nadie ha chocado con algo como esto antes??

por cierto un error que cometi al haer la imagen, en el ultimo paso ene l flujo de arriba que esta en color verde se buscan los registros cuyos id sean ">", no "=" sino los > 0

Buenas Dennis, cómo estás?

Las consultas son más fáciles de responder cuando se le quita la lógica propia de aplicación. Para comprender un poco tu problema tuve que leer varias veces el enunciado y analizar detenidamente la imagen.

Puedes por favor:

* acotar el ejemplo,

* mostrar los resultados obtenidos,

* detallar los resultados esperados y

* pasarnos la Transformation con datos de prueba.

Ya con esto le facilitarás la tarea de ayudarte a quien pase por aquí (me incluyo).

Saludos.

--

Ing. Bernabeu R. Dario
web | youtube | twitter

Saludos dario, que bueno saber de ti mano.

A ver te simplifico más la pregunta, en los pasos "depurar" y "depurar2" yo le asigno valores a la variable "idV".

en el paso "depurar" se da un valor mayor que 0

en el paso "depurar2" se da valor 0

entonces en el ultimo paso "Buscar mayores ultimo valor" se buscaba cuantas tuplas cumplian la condicion que el id de esa tabla fuera mayor que el valor que tenia la variable "idV" osea "SELECT * FROM TABLA WHERE id > idV"

no importa que valor tubiera "idV" el resultado debia ser multiple (si en la tabla existen 500 elementos y busco aquellos que su Id sea mayor que "idV" = 0 deben salir todos los elementos y si "idV" = 100 entonces deben salir como resultados 400). Pero no es esto lo que ocurre, siempre se obtenia un solo resultado que era el primero que cumplia la condición. Si "idV" = 0 se obtenia la tupla cuyo id era 1, si "idV" = 100 se obtenia la tupla cuyo id era 101. este era el problema que tenia dicho escenario

Saludos tropa, ya resolvi el problema. La solucion me llego cambiando el tipo de componente para hacer la busqueda, antes usaba un "Busqueda en base de datos" en su lugar utilice el componente "Consulta base de Datos" de esta manera ya si se me obtienen todas las tuplas que cumplan la condicion, les muestro con la imagen

Genial Dennis!

Gracias por compartir (como siempre) la solución.

Saludos

RSS

Distintivo

Cargando…

© 2017   Creado por Emilio.   Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio