Open Business Intelligence

La red del Business Intelligence

Buenas,

Tal vez alguien me pueda ayudar ya voy un par de dias en este problema y no encuentro solución.

Estoy creando una medida en Workbench de mi cubo que saque el "promedio" de notas.

Al momento de visualizarlo en el bi server no realiza el promedio me da como resultado la nota individual.

Que puedo estar haciendo mal.

Adjunto imagenes del workbench y el resultado en el bi server

Slds

Stef

Visitas: 242

Archivos adjuntos

Respuestas a esta discusión

Buenas stefy, cómo estás?

Intenta crear dos nuevas Medidas:

  • una de tipo SUM,
  • la otra de tipo COUNT.

Así al crear el análisis podemos verificar si está realizando bien o mal el cálculo del AVG.

Saludos

--

Ing. Bernabeu R. Dario
web | youtube | twitter

Buenas Bernabeu, gracias por responder.

Probe también con nuevas medidas como recomendaste. De igual manera no me suma ni cuenta el total por la definición.

Adjunto la imagen.

Algo podre estar haciendo mal?

Slds,

Stef

Archivos adjuntos

Buena Stef, cómo estás?

Creo que el problema está en otro lado. Fijate las tres columnas Suma, Contar y prom nota:

El cálculo de prom nota es correcto. Pero parece que está tomando un solo ítem.

Puedes pasarnos una screenshot de tu dw?

Saludos

Hola Bernabeu,

Despues de varios intentos logre solucionarlo.

Cree mis dimensiones y medidas; lo que añadi del diseño normal que tenía en estrella fue lo siguiente:

Cree "Dimension Usage" de mis dimensiones, asi pudo agrupar la información y me salió bien mi promedio por esa clasificación que deseaba.

Adjunto la imagen del diseño en schema workbench y la salida en el Bi Server.

Gracias por tu tiempo =)

Stf

Archivos adjuntos

Excelente. Muchas gracias por compartir la solución.

Saludos

RSS

Distintivo

Cargando…

© 2019   Creado por Emilio.   Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio