Open Business Intelligence

La red del Business Intelligence

Hola necesito ayuda
Estoy creando una xaction para familiarizarme con el design studio y me da el siguiente error

Failed
--------------------------------------------------------------------------------

Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)
Debug: Starting execute of CERES/dashboard/pruebachart.xaction (org.pentaho.platform.engine.services.solution.SolutionEngine)
Debug: Getting runtime context and data (org.pentaho.platform.engine.services.solution.SolutionEngine)
Debug: Loading action sequence definition file (org.pentaho.platform.engine.services.solution.SolutionEngine)
Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.platform.engine.services.solution.SolutionEngine)



Server Version: Pentaho Platform Engine Core 3.7.0-stable.44411

Aquí adjunto xaction
Gracias de antemano

Visitas: 1640

Archivos adjuntos

Respuestas a esta discusión

Te falta definir al menos un output, puedes arrastar la salida del sql (el resultset) a la parte de outputs.

 

Saludos

 

Mariano

Hola Mariano

Gracias !!! por contestar pero sigo con el mismo problema.

Estoy tratando de crear un dashboard guiandome por uno de los ejemplos que hay ahí pero no hay forma .Primero me sigue dando error .xaction y sin embargo sustituyo mi consulta para uno xaction del estos ejemplos y me funciona .en fin no se como hacerlo. Necesito lograr esto

Aqui te adjunto la xaction y los demas files

Gracias de antemano.

 

Archivos adjuntos

Eglys,

 

he probado ambas xactions con mis propias consultas y mi conexión y funcionan de 10, solo dos recomendaciones de la xaction que produce un gráfico:

1) en la consulta debes retorar una columna de tipo string que es la descripción del gráfico, ahora solo tienes 3 sum() y los gráficos no solo tienen valores, sino también descriptores de los valores.

2) en la salida, para eviar algo del estilo de: image-tag= .... debes configurar en las opciones de Opciones de Output Destination:

Destination     -       Name

response        -       content

 

saludos

 

Mariano

 

Gracias Mariano una vez mas

Ya no me sale el error en la xaction pero ahora cuando lo publico en el puc el grafico me sale como muestra la imagenq ue le adjunto.

Otra cosa como utilizo otra libreria de gráficos como openflashchart ?

 

Archivos adjuntos

Al tamaño del gráfico lo configuras con las propiedades Width y Heght del componente Pie Chart, y para que no salga image-tag= .... sigue las instrucciones de la respuesta anterior.

Saludos

Mariano

Mariano

cuando trato de correr una pequeña prueba de un dashborad ,ocurre el siguiente error que tiene que ver con la xaction que ya no me da error por si solo pero si cdo intento llamarla dentro del file template.xml. Aquí le adjunto el error y los files

por favor una vez recurro a su experiencia y gracias

Archivos adjuntos

Para hacer pruebas no tengo la BD (si la tuviese tampoco dispongo de tanto tiempo) , el error que adjuntas no sirve casi de nada, para poder analizar los errores hace falta el log de pentaho que se llama pentaho.log y está en el directorio bin de tomcat.

 

Saludos

 

Mariano

Esto es lo que tiene pentaho.log


2011-04-04 14:34:41,484 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:44,937 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:45,265 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:45,578 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:45,890 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:46,156 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:46,281 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:34:46,453 WARN  [org.apache.axis2.description.AxisService] Unable to generate EPR for the transport : http
2011-04-04 14:35:46,859 ERROR [org.pentaho.platform.web.servlet.GenericServlet] GenericServlet.ERROR_0004 - Resource /data-access/resources/gwt/nativeScripts.js not found in plugin Pentaho Data Access
2011-04-04 14:35:47,000 ERROR [org.pentaho.platform.web.servlet.GenericServlet] GenericServlet.ERROR_0004 - Resource /data-access/resources/gwt/gwt-dnd.css not found in plugin Pentaho Data Access
2011-04-04 14:35:49,218 ERROR [org.pentaho.platform.web.servlet.GenericServlet] GenericServlet.ERROR_0004 - Resource /data-access/resources/gwt/modeler_en.properties not found in plugin Pentaho Data Access
2011-04-04 14:35:49,312 ERROR [org.pentaho.platform.web.servlet.GenericServlet] GenericServlet.ERROR_0004 - Resource /data-access/resources/gwt/main_wizard_panel_en.properties not found in plugin Pentaho Data Access
2011-04-04 14:35:49,359 ERROR [org.pentaho.platform.web.servlet.GenericServlet] GenericServlet.ERROR_0004 - Resource /data-access/resources/gwt/main_wizard_panel_en_US.properties not found in plugin Pentaho Data Access
2011-04-04 14:37:08,125 WARN  [org.pentaho.platform.util.logging.Logger] misc-org.pentaho.platform.engine.core.system.PentahoSystem: PentahoSystem.WARN_OBJECT_NOT_CONFIGURED - Object with name "IUserDetailsRoleListService" has not been configured in the Pentaho object factory.
2011-04-04 14:37:09,421 ERROR [org.pentaho.platform.engine.services.solution.SolutionEngine] 8c85ecbf-5eea-11e0-a71e-a1512b02e06c:SOLUTION-ENGINE:PruebaChart.xaction: SolutionEngine.ERROR_0007 - Action sequence execution failed

Gracias !!

 

MMMM, solo eso tiene?

con eso no me doy ni una mínima idea de lo que puede estar pasado. Solo una pregunta, modificaste el template de CDF (.../pentaho-solutions/system/pentaho-cdf/template-dashboard.html) o estás usando el original?

Si lo modificaste, puede ser ese el problema, si quieres un template limpio te recomiendo hacer un backup del original y renombrar template-dashboard-clean.html a template-dashboard.html o bien agregar a tu archivo xcdf el tag style colocando como valor clean (agrego espacios a los tags para que se vean en este editor:


< cdf>

   ....

   ....

   < style>clean< /style>

< /cdf>

 

Saludos

 

Mariano


No modifique ese template.

Tengo dudas con esto. Lo que hice fue crear una carpeta dentro de mi solucion y alli tengo el file .xcdf, las xaction

y copie el file template.html en /pentaho-solutions/system/pentaho-cdf

dashboard_custom.xcdf

<?xml version="1.0" encoding="UTF-8"?>
<cdf>
    <title>Ceres Dashboard</title>
    <author>Desoft</author>
    <description>CERES Dashboard</description>
    <icon></icon>
    <template>template.html</template>
</cdf>

 

Puede ser así ?

 

el dashboard_custom.xcdf está bien, solo falta agregarle < style>clean< /style>, con respecto a copiar el template.html a donde indicas, no tiene ningún sentido ya que no lo está usando, el template.html tiene que estar en la misma carpeta que el archivo .xcdf

Saludos

Mariano

Hola Mariano

Gracias una vez mas pero vuelvo a estar en el mismo punto en que empecé,

cree una nueva xaction y el mismo error .Le adjunto pentaho.log que no dice mucho pero a lo mejor usted si le dice

agradezco su ayuda

Archivos adjuntos

RSS

Distintivo

Cargando…

© 2020   Creado por Emilio.   Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio