Open Business Intelligence

La red del Business Intelligence

Hola a todos, tengo la version de Pentaho 5.1 estable en un servidor con Windows Server 2012. 

Segun mi busqueda solamente tengo que configurar el archivo web.xml y el archivo server.xml cambiando la parte de localhost por la IP del servidor, ya lo hice pero no funciona.

Necesito que los usuarios puedan acceder a Pentaho desde cualquier equipo con acceso a internet.

Agradeceria mucho su ayuda!!

Visitas: 1845

Responde a esto

Respuestas a esta discusión

Yo uso el 5.0.1 lo he hecho asi y si que me ha funcionado....

¿Tienes el puerto abierto en el router?

Me imagino que estarás indicando el puerto 8080 en la dirección ¿no?

Un saludo

No lo cambie al 8081 pero intentare con el que viene por default.

Gracias por tu respuesta

inclusive ya abri el puerto 8080 en la configuracion de mi antivirus Nod32 pero aun asi no puedo acceder. Sugerencias ?

Hola Alex,

Te comento los pasos que hice yo.... ten en cuenta que no soy informatico y algunas cosas igual no las explico bien o son obvias.....

1.- Modificar este fichero C:\pentaho\biserver-ce\tomcat\webapps\pentaho\WEB-INF\web.xml

Cambiar la linea del localhost por la ippublica o el dominio que tengas:

<!-- FullyQualifiedServerUrl is used only in the case of offline content generation and whenever something need to talk back to the server -->
<context-param>
<param-name>fully-qualified-server-url</param-name>
<param-value>http://ippublicaodominio:8080/pentaho/</param-value>

2.- Configurar puertos en el router

En Advanced Setup  -> NAT virtual server

añadir una linea de este tipo

pentaho_user 8080 8080 TCP/UDP 8080 8080 ipdelpc ppp0.1

3.- En cualquier pc o tablet con acceso a internet (siempre desde una red externa) pongo 

http://ippublicaodominio:8080/pentaho/

y accede sin problemas

Vigila que no te esté bloquedando el firewall.....

Espero que te sirva... mas no se que decirte... como ya te he dicho no soy informatico....

Hola!!

Eh logrado poner el servicio de Pentaho del servidor en linea!!

Aparte de modificar el archivo web.xml (cosa que ya habia hecho) tuve que agregar una nueva regla dentro del firewall de windows la cual consiste en permitir entradas a partir del puerto 8080 tipo TCP.

En lo referente a modificar el router no hice nada ya que no entendi esa parte pero me funciono de maravilla lo demas.

Gracias!!

Responder a debate

RSS

Distintivo

Cargando…

© 2019   Creado por Emilio.   Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio