Open Business Intelligence

La red del Business Intelligence

Problema con Insert sobre una tabla simple en ORACLE

Estimados:

Estoy tratando de hacer un simple insert sobre un ORACLE10G y no he logrado hacerlo.. es para test son 12 registros, y el error que me da es el sgte.

 

2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : Because of an error, this step can't continue: 2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : org.pentaho.di.core.exception.KettleException: 2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : Error inserting row into table [PALABRAS_CLAVE] with values: [73], [SUPERMERCADO], [R], [S]2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : 2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : Error inserting/updating row2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : General error2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : 2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : org.pentaho.di.trans.steps.tableoutput.TableOutput.writeToTable(TableOutput.java:434)2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : org.pentaho.di.trans.steps.tableoutput.TableOutput.processRow(TableOutput.java:117)2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : org.pentaho.di.trans.step.RunThread.run(RunThread.java:40)2011/01/20 16:14:18 - Table output.0 - ERROR (version 4.1.0-stable, build 14410 from 2010-11-16 16.43.28 by buildguy) : java.lang.Thread.run(Unknown Source)

 

Alguien me podra dar una mano con esto ... sae lo agradeceria a miles!!!

Slds.

JC

 

Etiquetas: ORACLE10g, Pentaho

Visitas: 801

Las respuestas están cerradas para esta discusión.

Respuestas a esta discusión

Hola Javier,

la verdad que el error que devuelve la transformación no dice nada. ¿Has pulsado el botón para la generación del sql necesario?. Cuelga la transformación del foro porque al ser tan simple puede que haya algo básico que se escapa y no aparece en el log.

Un saludo.

Estimado:

Mira mi transformacion es super sencilla :

 

Paso 1:

 

 

Transformacion general desde un Excel a un Tabla ORACLE.

 

 

La configuracion del Excel es :

 

La Configuracion del ORACLE es:

 

 

Ayuda de algo??? realmente estoy un poco decepcionado del KETTLE estamos evaluando su uso en la compañia pero con este tipo de errores tan basicos que no me dicen nada y no tener donde buscar como que veo dificil implementar aqui, ojala me puedan dar una ayuda. Lo mas probable es que el problema sea yo pero las otras veces que he trabajado con PG y MySql no daba tantos dramas esta herramienta.

 

Slds y gracias a todos

JC

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hola JC,

 

Como el amigo "edu" dijo: ? has pulsado el botón SQL del tercer imagen, para creacionar la tabla de salida en el Banco MapChile ?  al final del error se ve : "Unknown Source" cerca de "Table output" .... eso sugiere que hay problemas en llegar al banco MapChile, target schema SBI, tabla PALABRAS_CLAVE.

 

Mira también si el target schema de esta tabla en MapChile es  "SBI", com hay en el imagen 3.  Mirando también este imagen, asegurate que las informaciones de la columna Stram Field están en el step "Select Values".

Además, si por casualidad has obtenido suceso alguna vez en esta transformación, un segundo intento trairia error pues el truncate table no está enable, eso si teneis en la tabla de salida alguna primary key.

 

Vicente de Paula :)

Hola Vicente... Gracias por tu ayuda te comento:

has pulsado el botón SQL del tercer imagen --> Sip de echo corrio un script pero veo en mi tabla y no aparecen las modificaciones que se hicieron.

asegurate que las informaciones de la columna Stram Field están en el step "Select Values". -> sip estan..

Además, si por casualidad has obtenido suceso alguna vez en esta transformación, un segundo intento trairia error pues el truncate table no está enable, eso si teneis en la tabla de salida alguna primary key. --> Esto no sucedera porque es una tabla que no tiene clave primaria porque quiero probar y luiego que logre implementar alguna cosa.

La unica duda que me queda es lo que lo referente al esquema ... y si esta accesando correctamente a el.. verificare eso y les comento.

Un gran saludos y gracias ..

 

JC

 

 

JC,

 

Si al pulsar el botón SQL nada se produjo en el banco DW (MapChile), hace una revisión en la conexión con este banco, como también en el propio Banco MapChile. El usuário utilizado en Kettle p/esta conexión debe tener derecho de creación y modificación de tablas e índices en MapChile.  Además, intenta dejar el campo target schema vacío, pulsar OK y volver a la ventana de propiedades de la tabla de salida y pulsar SQL.

 


En resumen el error dice lo siguiente...

Because of an error, this step can't continue:
 org.pentaho.di.core.exception.KettleException:
 Error inserting row into table [PALABRAS_CLAVE] with values: [73], [SUPERMERCADO], [R], [S]
 
 Error inserting/updating row
 General error
 
 org.pentaho.di.trans.steps.tableoutput.TableOutput.writeToTable(TableOutput.java:434)
 org.pentaho.di.trans.steps.tableoutput.TableOutput.processRow(TableOutput.java:117)
 org.pentaho.di.trans.step.RunThread.run(RunThread.java:40)
 java.lang.Thread.run(Unknown Source)

 

La "Fuente Desconocida" puede ser un problema de conexion, por lo tanto debes validar que la conexión esta correcta, ya sea que tu usuario tiene los permisos en la base de datos o que el usuario con el que ejecutaste kettle en linux tiene accesso. Tambien no olvides el tema del esquema y la base de datos, que sean los correctos...

 

Otra cosa, la asociación de los campos en el table output la hiciste de manera manual o con el field mapping??

 

Esta es de sapo... que haces en el select values???

 

Otra cosa 2, cuando ejecutaste el sql que te recomendaron arriba, que aparecia??, o sigue apareciendo la opción de ejecutar un script sql en tu base de datos????... Puedes colocar que te aparece y cual es la respuesta que te entrega el script?

Maestros... no saben!! lo que sucedia era que tenia que borrar la CACHE!!! ufff !! millones de vueltas hice eso y funco correctamente!!! Agradezco desde ya la ayuda de todos... lentamente voy avanzando!!! nuevamente millones de gracias!!!

 

JC

RSS

Distintivo

Cargando…

© 2019   Creado por Emilio.   Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio